Author Topic: Can't Attach Power data  (Read 6625 times)

5am

  • Newbie
  • *
  • Posts: 4
    • View Profile
Can't Attach Power data
« on: April 07, 2008, 06:38:57 PM »
First time user of topofusion after seeing an annoucement on the google wattage forum. I've exported a .tcx file of a ride from my Garmin 205 Forerunner. I then exported a powertap .csv file of the same ride from trainingpeaks wko software (file was originally imported as .csv file from my ibike power meter into trainingpeaks. Ibike and trainingpeaks are compatible and training peaks works flawlessly with ibike .csv files). I load the tcx file into topofusion then run power analysis adding the powertap .csv file. So far, I think this is the correct procedure as I read the manual.

When I run auto offset I get a -1722 power data offset figure and something like a 22 km/h mean error. The GPS file elapsed time is 2:17:08 and power elapsed time is 2:09:26.

All attempts to "attach" power data from the file to the tcx file fail.

Can anybody explain why the attach power attempt failed? Is the auto offset result simply too large? If I try to interpolate GPS to 1 second a get a window asking if I want to file a bug report.

Krein

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 1203
  • TopoFusion Author
    • View Profile
    • http://www.topofusion.com/diary
Can't Attach Power data
« Reply #1 on: April 07, 2008, 08:42:28 PM »
Sounds like you are doing everything right.

An offset of -1722 is about 28 minutes which does sound a little off, but it should still give you a valid attachment (it should still "work").

When you say that all attempts to attach power fail, how does it fail?  Does an error come up, or?

In any case, if you can send both of your files to support@topofusion.com we can take a look and get back to you.  

Thanks and sorry about the issues.

5am

  • Newbie
  • *
  • Posts: 4
    • View Profile
Can't Attach Power data
« Reply #2 on: April 08, 2008, 04:44:55 PM »
No error comes up upon hitting the attach power button. Nothing happens as far as I can see.

In any case, I'll email you the files per your suggestion. Many thanks in advance for any help.

Krein

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 1203
  • TopoFusion Author
    • View Profile
    • http://www.topofusion.com/diary
Can't Attach Power data
« Reply #3 on: April 08, 2008, 04:52:37 PM »
Go to Map->Track Shading and choose Power.

Sounds like it is working in that it's adding more data to your TCX file.  (Also profile the track and you'll see power data).

Now, whether or not the offset is correct is a different issue.  I'll take a look when I get the files.  Thanks.

5am

  • Newbie
  • *
  • Posts: 4
    • View Profile
Can't Attach Power data
« Reply #4 on: April 09, 2008, 11:02:31 AM »
Sorry for the delay, but files emailed today.

Krein

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 1203
  • TopoFusion Author
    • View Profile
    • http://www.topofusion.com/diary
Can't Attach Power data
« Reply #5 on: April 09, 2008, 04:20:50 PM »
Thanks for sending the files!  The iBike threw a bit of a wrench in things since it doesn't record Torque!  

I guess none of our testers used an iBike -- PowerTap and SRM both give torque, which of course isn't necessary since TF doesn't use it, but it messed up the input routine.

I've fixed it and will have a new version out, likely tomorrow.  I also fixed the interpolate function.

But in the meantime, here is a TCX file of your ride with power:  The auto-offset came out at ~320 seconds.


http://www.topofusion.com/GPX/4_4_2008_with_power.tcx




5am

  • Newbie
  • *
  • Posts: 4
    • View Profile
Can't Attach Power data
« Reply #6 on: April 09, 2008, 10:41:27 PM »
Thanks very much! Will look over the file and download the latest version when you've got it up.

Still not sure of the ins and outs of the auto offset. Perhaps when you get a chance at some point you might add more detail to your program FAQ. I never was very good at math!

Krein

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 1203
  • TopoFusion Author
    • View Profile
    • http://www.topofusion.com/diary
Can't Attach Power data
« Reply #7 on: April 10, 2008, 09:18:59 AM »
New version is out with the fix.

Yep, some more detail on how the auto works would help.  I think you'll find it much easier now that it's actually reading your data files correctly!